Setting DNS Server MikroTik Agar Lebih Cepat & Stabil

Permasalahan yang sering terjadi dalam melakukan setting dns server pada router mikrotik yaitu koneksi internet lebih lambat dibandingkan saat menggunakan modem untuk akses internet secara langsung.

Untuk mengatasi masalah tersebut sebenarnya cukup mudah, yaitu dengan menggunakan DNS bawaan ISP itu sendiri. Namun terkadang DNS dari ISP ini sering memblokir situs-situs tertentu dan terkadang juga sangat lambat.

Baca juga : Mengubah Server DNS untuk mempercepat koneksi internet

Selain itu, kita juga dapat mengatasi masalah tersebut dengan mencentang allow remote request agar router mikrotik di jadikan sebagai dns server. Nantinya komputer client tidak perlu mengisi DNS publik lagi.

Namun akan ada masalah lain lagi setelah allow remote request di centang, yaitu adanya serangan dns attack melalui port DNS (port 53). Hal ini membuat koneksi internet anda akan semakin lambat. Untuk itulah pada artikel ini saya akan memberikan tutorial optimasi setting DNS server mikrotik agar lebih cepat dan responsif.

DNS Server Yang Di Gunakan Pada Mikrotik

DNS adalah protokol yang bertugas mengubah atau menerjemahkan IP Address menjadi nama domain /web url. Ada beberapa sever DNS yang bisa digunakan untuk setting pada router mikrotik, diantaranya :

  • DNS Google (8.8.8.8 dan 8.8.4.4)
  • Cloudflare (1.1.1.1 dan 1.0.0.1)
  • OpenDNS (208.67.222.222 dan 208.67.220.220)
  • Quad9 (9.9.9.9 dan 149.112.112.112 )
  • Dan lain-lain

Setting DNS Server Pada Router Mikrotik

Berikut ini optimasi setting DNS server mikrotik agar lebih cepat dan responsif.

  • Login ke router mikrotik menggunakan aplikasi winbox,
  • Klik menu IP dan pilih DNS
  • Tambahkan beberapa DNS seperti google,cloudflare,dan lain-lain pada menu Servers
  • Centang allow remote requests
  • Set cache size jadi 5000 dan chache max TTL menjadi 1d
Setting DNS server MikroTik

Berikut ini script pada settingan diatas yang dapat anda salin langsung ke terminal mikrotik:

/ip dns set allow-remote-requests=yes cache-max-ttl=1d cache-size=5000KiB servers=8.8.8.8,8.8.4.4,1.1.1.1,9.9.9.9,208.67.220.220,208.67.222.222

Mengatasi DNS Attack Pada Router MikroTik

Selanjutnya, kita akan melakukan setting pada firewall NAT dan filter untuk menghindari adanya DNS Attack. Silahkan salin script dibawah ini lalu tempelkan di terminal mikrotik

Script untuk Setting Pada Firewall NAT

/ip firewall nat
add action=redirect chain=dstnat dst-port=53 protocol=tcp to-ports=53
add action=redirect chain=dstnat dst-port=53 protocol=udp to-ports=53

Script untuk Setting Pada Firewall Filter

/ip firewall filter 
add action=drop chain=input dst-port=53 in-interface=ether2 protocol=tcp
add action=drop chain=input dst-port=53 in-interface=ether2 protocol=udp

Begitulah cara optimasi setting DNS server mikrotik agar lebih cepat dan responsif. Dengan menggunakan settingan DNS dan beberapa script di atas, maka akan mencegah jika terjadi gangguan dari luar sehingga koneksi internet pada router mikrotik anda akan sama cepat nya dengan menggunakan modem ISP.

Tinggalkan Balasan

Scroll to Top